Manually updating rubygems

Announcement (2017-05-07): now read-only since I unfortunately do not have the time to support and maintain the forum any more. * Gem:: Package Task depends on the package dir like the other rake package tasks so dependencies can be hooked up correctly. It turned out that rdoc_osx_dictionary, with its rubygems plugin, was what was killing my gems, rdoc, and the whole bit.

Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms. If you really liked it, see Gem:: Config File to learn how to set it by default. * Gem:: Dependency support #version_requirements= with a warning. The situation was so bad that I couldn't even get gem to uninstall rdoc_osx_dictionary - I had to rip it physically out of the computer in order for gem to work at all.

Earlier when attempting to install the request-log-analyzer gem on a Cent OS Linux server I ran into some issues.

manually updating rubygems-39

Gem Command Version Output: So I figured that maybe if I cleaned up the previous installs of rubygems-update that it would resolve the issue.

I cleaned up the previous versions by issuing the “gem cleanup” command which did remove the previous versions of the rubygems-update gem however the gem command still output version 1.1.1.

If you saw something different, you haven’t set your path correctly.

which will work on Ubuntu 12.04, throws up an error on 14.04 because ruby1.8 is a bit outdated and has been removed from the official ubuntu 14.04 repositories, but my application is yet to be ported to the newer ruby versions.

Ruby Gems is a package management framework for Ruby. You must have an installation of Ruby Gems before this update can be applied. (This change was made in 1.3.6) * Ruby Gems now has platform support for Iron Ruby. Bug fixes: * Require rubygems/custom_require if --disable-gem was set. * Ruby Gems now protects against exceptions being raised by plugins. It sounds like this feature will protect against this kind of vicious circle.

See Gem for information on Ruby Gems (or `ri Gem`) To upgrade to the latest Ruby Gems, run: $ gem update --system # you might need to be an administrator or root NOTE: Ruby Gems 1.1 and 1.2 have problems upgrading when there is no rubygems-update installed. update --system Updating Ruby Gems Updating rubygems-update Successfully installed rubygems-update-1.3.7 Updating Ruby Gems to 1.3.7 Installing Ruby Gems 1.3.7 ERROR: While executing gem ...

The error was that the gem required a newer version of another gem.

I started looking further into the issue and noticed that the first server showed only version 1.3.1 of the rubygems-update gem but the second server showed rubygems-update versions 1.3.1, 1.3.0, and 1.1.1 installed.

I have done the "gem update --system" command, and successfully updated to Ruby Gems 1.3.6.

The problem is, Netbeans is not recognizing that I have updated it, even after restarting Netbeans.

Once you’ve updated the Rails gems, the only remaining step to upgrading your individual Rails applications (Version 0.14.0 and later) is to get the latest Java Script libraries.

Comments are closed.